<!DOCTYPE html>
<html lang='en'>
<head>
<meta charset="utf-8">
<meta http-equiv="x-ua-compatible" content="ie=edge"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="description" content="The chairs of Dallas County's Republican and Democratic parties weigh in following election night.">
<script>var DMAG = DMAG || {};</script>
<title>Party Chairs Reflect on a Night of Turnover in Dallas County - D Magazine</title>

<meta name="description" content="The chairs of Dallas County&#039;s Republican and Democratic parties weigh in following election night." />
<link rel="canonical" href="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Party Chairs Reflect on a Night of Turnover in Dallas County - D Magazine" />
<meta property="og:description" content="The chairs of Dallas County&#039;s Republican and Democratic parties weigh in following election night." />
<meta property="og:url" content="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/" />
<meta property="og:site_name" content="D Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/DMagazineOnline/" />
<meta property="article:tag" content="Pete Sessions" />
<meta property="article:tag" content="Ted Cruz" />
<meta property="article:tag" content="Faith Johnson" />
<meta property="article:tag" content="Colin Allred" />
<meta property="article:tag" content="Matt Rinaldi" />
<meta property="article:tag" content="Beto O&#039;Rourke" />
<meta property="article:tag" content="Julie Johnson" />
<meta property="article:tag" content="John Creuzot" />
<meta property="article:section" content="Local Government" />
<meta property="article:published_time" content="2018-11-07T12:32:13-06:00" />
<meta property="article:modified_time" content="2018-11-07T12:35:31-06:00" />
<meta property="og:updated_time" content="2018-11-07T12:35:31-06:00" />
<meta property="og:image" content="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM.png" />
<meta property="og:image:secure_url" content="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM.png" />
<meta property="og:image:width" content="595" />
<meta property="og:image:height" content="446" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The chairs of Dallas County&#039;s Republican and Democratic parties weigh in following election night." />
<meta name="twitter:title" content="Party Chairs Reflect on a Night of Turnover in Dallas County - D Magazine" />
<meta name="twitter:site" content="@DMagazine" />
<meta name="twitter:image" content="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM.png" />
<meta name="twitter:creator" content="@DMagazine" />

<link rel='dns-prefetch' href='//www.dmagazine.com' />
<link rel='dns-prefetch' href='//cloud.typography.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="D Magazine &raquo; Party Chairs Reflect on a Night of Turnover in Dallas County Comments Feed" href="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.dmagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css' href='https://www.dmagazine.com/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1541623610' type='text/css' media='all' />
<link rel='stylesheet' id='sage/css-css' href='https://www.dmagazine.com/wp-content/themes/dmagazine/dist/styles/main-a31323d539.css' type='text/css' media='all' />
<link rel='stylesheet' id='fonts-css' href='https://cloud.typography.com/6172774/6791152/css/fonts.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.dmagazine.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","action":"update_views_ajax","ID":"519775","token":"fdcdfe2e7d","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.1.0.min.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.dmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.dmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.dmagazine.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.dmagazine.com/?p=519775' />
<link rel="alternate" type="application/json+oembed" href="https://www.dmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.dmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.dmagazine.com/?wordfence_lh=1&hid=0E324337E699397481912616AFCCF2FA');
</script>

<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0" />
<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.dmagazine.com\/frontburner\/2018\/11\/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county\/"},"headline":"Party Chairs Reflect on a Night of Turnover in Dallas County","url":"https:\/\/www.dmagazine.com\/frontburner\/2018\/11\/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county\/","thumbnailUrl":"https:\/\/assets.dmagstatic.com\/wp-content\/uploads\/2018\/11\/Screen-Shot-2018-11-07-at-10.13.24-AM-150x150.png","image":{"@type":"ImageObject","url":"https:\/\/assets.dmagstatic.com\/wp-content\/uploads\/2018\/11\/Screen-Shot-2018-11-07-at-10.13.24-AM-150x150.png"},"dateCreated":"2018-11-07T18:32:13Z","datePublished":"2018-11-07T18:32:13Z","dateModified":"2018-11-07T18:32:13Z","articleSection":"FrontBurner","author":[{"@type":"Person","name":"Shawn Shinneman"}],"creator":["Shawn Shinneman"],"keywords":["pete sessions","ted cruz","faith johnson","colin allred","matt rinaldi","beto o'rourke","julie johnson","john creuzot"],"publisher":{"@type":"Organization","name":"D Magazine","logo":{"@type":"ImageObject","url":"https:\/\/www.dmagazine.com\/wp-content\/uploads\/2015\/09\/d-logo-square-facebook-default.jpg"}}}
	</script>

<link rel="icon" href="https://www.dmagazine.com/wp-content/uploads/2015/09/d-logo-square-facebook-default-300x300.jpg" sizes="32x32" />
<link rel="icon" href="https://www.dmagazine.com/wp-content/uploads/2015/09/d-logo-square-facebook-default-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.dmagazine.com/wp-content/uploads/2015/09/d-logo-square-facebook-default-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://www.dmagazine.com/wp-content/uploads/2015/09/d-logo-square-facebook-default-300x300.jpg" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-466309-20', 'auto');
  ga('send', 'pageview');
</script>


<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '359885427553227'); // Insert your pixel ID here.
fbq('track', 'PageView');

fbq('track', 'FrontburnerPageView');

</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=359885427553227&ev=PageView&noscript=1"
/></noscript>


<script> var $ = jQuery; </script>
</head>
<body data-rsssl=1 class=" layout--with-sidebar page--story page--party-chairs-reflect-on-a-night-of-turnover-in-dallas-county">
<div class="nav-drawer is-hidden--medium_small">
<div class="container nav-drawer__items">
<div class="nav-drawer__item">
<img class="image lazyload" data-srcset="https://assets.dmagstatic.com/wp-content/uploads/2018/10/d-magazine-november-2018-330x495.jpg 330w,
		https://assets.dmagstatic.com/wp-content/uploads/2018/10/d-magazine-november-2018-677x1016.jpg 677w" sizes="(max-width: 720px) ,
			330px" data-src="https://assets.dmagstatic.com/wp-content/uploads/2018/10/d-magazine-november-2018-330x495.jpg" />
<div class="nav-drawer__item__overlay">
<a class="button button--small button--blue button--full" href="https://www.dmagazine.com/publications/d-magazine/2018/november/">
View Issue
</a>
<a class="button button--blue button--small button--full" href="/site/subscribe">
Subscribe
</a>
</div>
<h4 class="nav-drawer__item__title">D Magazine</h4>
</div>
<div class="nav-drawer__item">
<img class="image lazyload" data-srcset="https://assets.dmagstatic.com/wp-content/uploads/2018/10/DCEO_11-18_Cover-330x495.jpg 330w,
		https://assets.dmagstatic.com/wp-content/uploads/2018/10/DCEO_11-18_Cover-677x1016.jpg 677w" sizes="(max-width: 720px) ,
			330px" data-src="https://assets.dmagstatic.com/wp-content/uploads/2018/10/DCEO_11-18_Cover-330x495.jpg" />
<div class="nav-drawer__item__overlay">
<a class="button button--small button--blue button--full" href="https://www.dmagazine.com/publications/d-ceo/2018/november/">
View Issue
</a>
<a class="button button--blue button--small button--full" href="/site/subscribe">
Subscribe
</a>
</div>
<h4 class="nav-drawer__item__title">D CEO</h4>
</div>
<div class="nav-drawer__item">
<img class="image lazyload" data-srcset="https://www.dmagazine.com/wp-content/uploads/2018/08/DHome-SeptOct-Cover-330x495.jpg 330w,
		https://www.dmagazine.com/wp-content/uploads/2018/08/DHome-SeptOct-Cover-677x1016.jpg 677w" sizes="(max-width: 720px) ,
			330px" data-src="https://www.dmagazine.com/wp-content/uploads/2018/08/DHome-SeptOct-Cover-330x495.jpg" />
<div class="nav-drawer__item__overlay">
<a class="button button--small button--blue button--full" href="https://www.dmagazine.com/publications/d-home/2018/september-october/">
View Issue
</a>
<a class="button button--blue button--small button--full" href="/site/subscribe">
Subscribe
</a>
</div>
<h4 class="nav-drawer__item__title">D Home</h4>
</div>
</div>
</div>
<header class="nav">
<div class="nav-inner">
<div class="nav__main__search">
<button type="button" class="search__icon js-searchButton">
<svg class="icon icon--small icon--white" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><circle class="icon__main icon--stroke" fill="none" stroke="#000000" stroke-miterlimit="10" cx="22" cy="22" r="18" /><path class="icon__main icon--switch" d="M37,32l20.998,16.1C59.236,49.361,60,51.092,60,53c0,3.866-3.134,7-7,7c-1.959,0-3.73-0.805-5.002-2.103L32,37" /></svg>
</button>
<form action="//search.dmagazine.com" class="search__form js-searchForm">
<input class="search__input js-searchInput" type="text" name="q" placeholder="Search" />
</form>
</div>
<a class="nav__logo" href="/">
<img class="nav__logo__image" src="https://www.dmagazine.com/wp-content/themes/dmagazine/dist/images/dmag-logo_180x164.png" />
</a>
<button class="nav__button is-hidden--large-only js-slide-trigger">
<div class="js-slide-switch">
<svg class="icon icon--white" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><g><rect class="icon__main icon--fill" x="9" y="29" width="46" height="7" /></g><g><rect class="icon__main icon--fill" x="9" y="13" width="46" height="7" /></g><g><rect class="icon__main icon--fill" x="9" y="44" width="46" height="7" /></g></svg>
</div>
<div class="is-hidden js-slide-switch">
<svg class="icon icon--white" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><line class="icon__main icon--stroke" fill="none" stroke="#000000" stroke-miterlimit="10" x1="23" y1="23" x2="41" y2="41" /><line class="icon__main icon--stroke" fill="none" stroke="#000000" stroke-miterlimit="10" x1="41" y1="23" x2="23" y2="41" /></svg>
</div>
</button>
<div class="nav__main-wrapper">
<div class="nav__main-wrapper-inner">
<nav class="nav__main nav__main--secondary">
<div class="nav__main__items">
<ul>
<li class="nav__main__item">
<a class="nav__main__link" href="https://directory.dmagazine.com/?ref=nav">
Directories
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://events.dmagazine.com/?ref=nav">
Events
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/category/podcast/?ref=nav">
Podcasts
</a>
</li>
<li class="nav__main__item nav__main__item--magazines">
<a class="nav__main__link js-slide-trigger" href="#">
Magazines
<div class="nav__main__icon is-hidden--medium_small">
<div class="js-slide-switch">
<svg class="icon icon--blue icon--small" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><circle class="icon__main icon--switch" cx="32" cy="32" r="29" /><line class="icon__accent icon--stroke" fill="none" stroke="#FFFFFF" stroke-miterlimit="10" x1="20" y1="32" x2="44" y2="32" /><line class="icon__accent icon--stroke" ill="none" stroke="#FFFFFF" stroke-miterlimit="10" x1="32" y1="20" x2="32" y2="44" /></svg>
</div>
<div class="js-slide-switch is-hidden">
<svg class="icon icon--blue icon--small" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><circle class="icon__main icon--switch" cx="32" cy="32" r="29" /><line class="icon__accent icon--stroke" fill="none" stroke="#FFFFFF" stroke-miterlimit="10" x1="20" y1="32" x2="44" y2="32" /></svg>
</div>
</div>
</a>
</li>
<li class="nav__main__item nav__main__item--subscribe">
<a class="nav__main__link" href="/site/subscribe/">
Subscribe
</a>
</li>
<li class="nav__main__item nav__main__item--feedback">
<a class="nav__main__link" href="https://dmagazine.wufoo.com/forms/dmagazinecom-feedback/" target="_blank">
Leave Us Feedback
</a>
</li>
</ul>
</div>
</nav>
<nav class="nav__main nav__main--primary">
<ul class="nav__main__items">
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/frontburner/?ref=nav">
News
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/food-drink/?ref=nav">
Food
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/arts-entertainment/?ref=nav">
Arts
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/home-garden/?ref=nav">
Home
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/health-fitness/?ref=nav">
Health
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/philanthropy-nonprofits/?ref=nav">
Charity
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="https://www.dmagazine.com/section/business-economy/?ref=nav">
Business
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="http://www.dweddings.com/?ref=nav">
Weddings
</a>
</li>
<li class="nav__main__item">
<a class="nav__main__link" href="http://neighborhoods.dmagazine.com/?ref=nav">
Neighborhoods
</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
</header>
<div class="container nav__tagline-wrapper is-hidden--medium_small">
<div class="nav__tagline">
Let’s Make Dallas Even Better
</div>
</div>
<div class="site-wrapper">
<div class="is-loading-overlay is-hidden">
<img class=" is-loading-overlay__loader" src="https://www.dmagazine.com/wp-content/themes/dmagazine/dist/images//DMagazine_load.gif" alt="loading">
</div>
<div class="adunit adunit--horizontal adunit--desktop  adunit--horizontal-top" data-adunit="MissEllie_horizontal_top" data-mapping="mapping_horizontal_desktop">
</div>
<div class="story-wrapper js-stickyParent" role="document">
<main class="main">
<article class="story  ">
<header class="story__header">
<figure>
<div class="story__image">
<div class="image ar-content">
<img class="image" srcset="									
			https://assets.dmagstatic.com/wp-content/uploads/2018/11/General_4-330x220.jpg
	 330w,
												
			https://assets.dmagstatic.com/wp-content/uploads/2018/11/General_4-677x451.jpg
	 677w,
												
			https://assets.dmagstatic.com/wp-content/uploads/2018/11/General_4-1024x683.jpg
	 1024w,
												
			https://assets.dmagstatic.com/wp-content/uploads/2018/11/General_4-1200x800.jpg
	 1200w" sizes="(max-width: 1024px) 100vw,
			677px" src="									
			https://assets.dmagstatic.com/wp-content/uploads/2018/11/General_4-677x451.jpg
	 " />
</div>
</div>
<figcaption class="story__image-caption--header story__image-caption">
<span>Political signs outside the Oak Lawn Branch Library on Election Day. (Photo by Creagh Cross.)</span>
<span class="image-caption__credit"></span>
</figcaption>
</figure>
<div class="story__header__content">
<h2 class="category"><a href="https://www.dmagazine.com/category/politics-and-government/?ref=kicker">Politics &amp; Government</a></h2>
<h1 class="story__title">Party Chairs Reflect on a Night of Turnover in Dallas County</h1>
<p class="story__subhead">The chairs of Dallas County's Republican and Democratic parties weigh in following election night.</p>
<div class="story__info">
<span class="story__info__item">By
<a href="https://www.dmagazine.com/author/shawn-shinneman/">
Shawn Shinneman
</a>
</span>
<span class="story__info__item">
Published in
<a href="https://www.dmagazine.com/section/frontburner/">
FrontBurner
</a>
</span>
<span class="story__info__item">
November 7, 2018
</span>
<span class="story__info__item">
12:32 pm
</span>
</div>
</div>
</header> <div class="story__body">
<div class="social-buttons social-buttons--style1">
<div class="social-buttons-inner">
<a class="social-button button--sms is-hidden--large_medium" target="_blank" href="sms:?&body=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F">
<div class="social-button-inner">
<span class="icon">SMS</span>
</div>
</a>
<a class="social-button button--facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F&title=Party%20Chairs%20Reflect%20on%20a%20Night%20of%20Turnover%20in%20Dallas%20County" rel="external nofollow">
<div class="social-button-inner">
<svg class="icon " version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><path class="icon__main icon--fill" d="M25,22h-8v10h8v28h12V32h9l1-10H37v-4c0-2,1-3,3-3h7V4h-8c-8.688,0-14,2-14,11V22z" /></svg>
</div>
</a>
<a class="social-button button--twitter" target="_blank" href="https://twitter.com/intent/tweet?text=Party%20Chairs%20Reflect%20on%20a%20Night%20of%20Turnover%20in%20Dallas%20County&url=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F" rel="external nofollow">
<div class="social-button-inner">
<svg class="icon " version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><path class="icon__main icon--fill" d="M62,13c-2.207,0.99-4,2-7,2c2.546-1.532,4.084-3.11,5-6c-2.375,1.417-4,2-7,3c-2.242-2.403-5.462-5-9-5
	c-7.949,0-13.791,7.261-12,15c-10.223-0.515-19.93-4.51-26-12c-3.228,5.563-1.476,12.314,4,16c-2.005-0.065-4.344-1.072-6-2
	c-0.131,5.737,4.083,11.808,10,13c-1.733,0.472-3.066,0.369-5,0c1.568,4.914,5.608,7.895,11,8c-5.171,4.078-11.473,6.771-18,6
	c5.452,3.506,12.048,6,19,6c22.853,0,35.784-19.592,35-37C58.405,18.253,60.352,15.482,62,13z" /></svg>
</div>
</a>
<a class="social-button button--pinterest" target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.dmagazine.com%2Ffrontburner%2F2018%2F11%2Fparty-chairs-reflect-on-a-night-of-turnover-in-dallas-county%2F&media=https%3A%2F%2Fassets.dmagstatic.com%2Fwp-content%2Fuploads%2F2018%2F11%2FScreen-Shot-2018-11-07-at-10.13.24-AM.png&description=Party%20Chairs%20Reflect%20on%20a%20Night%20of%20Turnover%20in%20Dallas%20County" rel="external nofollow">
<div class="social-button-inner">
<svg class="icon " version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><path class="icon__main icon--fill" d="M32,4C16.538,4,4,16.534,4,32c0,11.863,7.585,21.921,18,26c-1-2-0.565-6.58,0-9c0.51-2.185,3.467-13.267,3.467-13.267
	S24,34.48,24,32c0-3.892,2.189-7,5-7c2.386,0,4,1.85,4,4c0,2.4-2.21,5.671-3,9c-0.661,2.786,2.251,5,5,5c4.977,0,8-5.428,8-13
	c0-6.704-4.124-11-11-11c-7.966,0-13,5.826-13,12c0,2.406,0.844,5.601,2,7c0.229,0.277,1.067,0.718,1,1l-1,2
	c-0.123,0.513-0.467,1.248-1,1c-3.497-1.627-6-6.894-6-11c0-8.832,6.914-17,19-17c9.712,0,17,6.75,17,16c0,9.65-6.551,18-15,18
	c-2.835,0-5.087-1.256-6-3l-2,7c-0.632,2.434-1.856,5.143-3,7c2.623,0.812,5.114,1,8,1c15.462,0,28-12.538,28-28
	C60,16.534,47.462,4,32,4z" /></svg>
</div>
</a>
<div class="social-button button--comments">
<div class="social-button-inner">
<a href="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/#jump-comments">
<svg class="icon " version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><path class="icon__main icon--switch" d="M32,5C15.983,5,3,15.298,3,28c0,7.309,4.304,13.816,11.005,18.029L16,59l16-8c16.017,0,29-10.298,29-23S48.017,5,32,5z" /><circle class="icon__accent icon--switch" fill="#FFFFFF" cx="32" cy="28" r="4" /><circle class="icon__accent icon--switch" fill="#FFFFFF" cx="18" cy="28" r="4" /><circle class="icon__accent icon--switch" fill="#FFFFFF" cx="46" cy="28" r="4" /></svg>
<span class="disqus-comment-count" data-disqus-url="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/#disqus_thread"></span>
</a>
</div>
</div>
</div>
</div>
<div class="story__content-l story__content story__content--is-slideshow-closed">
<p class="p1">U.S. Senate hopeful Beto O’Rourke’s near miss might be grabbing the national headlines, but Dallas County’s Democratic Party is in high spirits on Wednesday. The party helped young Democrat Colin Allred unseat long-running Republican Congressman Pete Sessions, saw wins in key state senate races, and ushered in a run of Democrats within the judicial system that includes a return to a blue district attorney.</p>
<p class="p1">“The blue wave was definitely here,” declared the party’s county chair, Carol Donovan. “We swept practically every race we had.”</p>
<p class="p1">It was a night of upsets. Allred, an attorney and former NFL player, knocked off Sessions, a name that’s become synonymous with North Texas politics, whose run in Congress dated back to 1997. “You believed in us when all the pundits didn’t,” Allred told his watch party at Dallas’ Magnolia Hotel Park Cities.</p>
<p class="p1">In a race <a href="https://www.dmagazine.com/publications/d-magazine/2018/november/matt-rinaldis-reelection-battle-could-signal-how-democrats-will-fare/" target="_blank" rel="noopener">we noted</a> could be key for Democrats, Julie Johnson (D) knocked of D-115 incumbent Matt Rinaldi (R) by a sizable 56.7 percent to 43.3 percent margin. And, in one that Dallas County Republican Chair Missy Shorey singled out as one of the biggest surprises, Ana-Maria Ramos (D) took the seat from D-102’s Linda Koop (R), who Shorey called “an outstanding representative.” Those suburban districts span Irving, Addison, and Richardson. Overall, five seats in the Texas house turned blue among 11 flips across the state.</p>
<figure id="attachment_519795" class="wp-caption alignleft size-dmag-small"><a href="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM.png"><img class="wp-image-519795" src="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM-330x220.png" alt="" width="330" height="220" srcset="https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM-330x220.png 330w, https://assets.dmagstatic.com/wp-content/uploads/2018/11/Screen-Shot-2018-11-07-at-10.13.24-AM-504x336.png 504w" sizes="(max-width: 580px) 100vw, 330px" /></a><figcaption style="max-width:330px;" class="wp-caption-text"><span>The blue wave—or ripple—in motion, via <em>The Guardian</em>.</span></figcaption></figure>
<p class="p1">Shorey says the party will take time to reflect, assess what went wrong, and look at “how we address the needs of voters going forward.” She credited the grassroots efforts of the Republican party toward uniting voters, referencing the <a href="https://www.dmagazine.com/publications/d-magazine/2018/february/missy-shorey-dallas-county-republican-party/" target="_blank" rel="noopener"><i>D Magazine</i> story</a> about that impossible task. And she said that she will be getting to work. “I’m not crying, I’m not protesting, and I’m not marching in the streets,” said Shorey.</p>
<p class="p1">In the DA race, Republican incumbent Faith Johnson’s tenure came to an abrupt end, after she was appointed to the position by Gov. Greg Abbott in late 2016. She replaced Republican Susan Hawk, who defeated Craig Watkins but stepped down <a href="https://www.dmagazine.com/publications/d-magazine/2015/november/dallas-district-attorney-susan-hawk-untold-story/" target="_blank" rel="noopener">to address her mental health</a>. She was largely absent from her office, and Johnson has been credited with bringing stability back to the office. She&#8217;d also stepped in front of news cameras multiple times in recent months, including after securing a conviction of a police officer who shot and killed 15-year-old Balch Springs teenager Jordan Edwards.</p>
<p class="p1">She ran against the reform-minded John Creuzot, a former judge, who now takes over with an agenda to shorten or eliminate jail time for lesser crimes like small-scale marijuana possession. As a judge in Dallas County, Creuzot pioneered a diversion court for certain offenders with no prior record. “He continues to believe in the ideal of second chances on crimes that don’t endanger the people of Dallas County,” Donovan said. During a phone call Wednesday morning, Creuzot’s was the first victory she highlighted.</p>
<p class="p1">Another big swing she pointed toward: the justices of the 5th Court of Appeals District, which encompasses Grayson, Collin, Hunt, Rockwall, Dallas, and Kaufman counties. All eight spots up for grabs went to Democrats. It was previously an all-Republican bench, and the local Democratic party branded the judges as the Slate of Eight. “We knew it would be a long shot since we had to get the cooperation from multiple counties,” said Donovan.</p>
<p class="p1">In a nonpartisan portion of the ballot, Dallas ISD went four for four, including a Prop C victory in which voters passed a Tax Ratification Election. It’ll help the district continue to put money into programs that have fueled a turnaround, allowing more choices and better teachers for students in economically challenging situations. “We put this on the ballot when there would be a huge voter turnout,” Superintendent Michael Hinojosa said before the election. “Other districts have tried to do it on non-uniform election days. We’re trying to be transparent.” Similar tax increases were approved for Richardson and Collin County ISDs.</p>
<p class="p1">Meanwhile, the 13-person race for Dwaine Caraway’s spot on the Dallas City Council is headed to a runoff between former Council Member Carolyn King Arnold and 28-year-old activist Keyaira Saunders.</p>
<p class="p1">Turnout played a key role in it all. For that, Donovan credited the Trump effect. And, despite the loss, O’Rourke’s presence was felt.</p>
<p class="p1">“I was talking to one of my colleagues and they said if Beto hadn’t run here, there wouldn’t be these wins,” Shorey said. “They’re absolutely right.”</p>
</div>
</div>
<div class="story__footer">
<ul class="story__categories">
<li class="story__category">
<a class="story__category__link" href="https://www.dmagazine.com/category/local-government/">
Local Government
</a>
</li>
<li class="story__category">
<a class="story__category__link" href="https://www.dmagazine.com/category/local-news/">
Local News
</a>
</li>
<li class="story__category">
<a class="story__category__link" href="https://www.dmagazine.com/category/politics/">
Politics
</a>
</li>
<li class="story__category">
<a class="story__category__link" href="https://www.dmagazine.com/category/politics-and-government/">
Politics &amp; Government
</a>
</li>
</ul>
<div class="story__tags">
<span class="story__tags-title">Tags:</span>
<ul>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/pete-sessions/">
Pete Sessions
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/ted-cruz/">
Ted Cruz
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/faith-johnson/">
Faith Johnson
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/colin-allred/">
Colin Allred
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/matt-rinaldi/">
Matt Rinaldi
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/beto-orourke/">
Beto O'Rourke
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/julie-johnson/">
Julie Johnson
</a>
</li>
<li class="story__tag">
<a class="story__tag__link" href="https://www.dmagazine.com/tag/john-creuzot/">
John Creuzot
</a>
</li>
</ul>
</div>
</div>
</article>
<svg class="icon story__scrollArrow icon--blue js-scrollArrow" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><circle class="icon__main icon--switch" cx="32" cy="32" r="29" /><polyline class="icon__accent icon--stroke" fill="none" stroke="#FFFFFF" stroke-miterlimit="10" points="42,35 32,25 22,35 " /></svg>
</main>
<aside class="sidebar">
<div class="adunit adunit--vertical adunit--top  widget--sidebaradunit--vertical-top" data-adunit="MissEllie_vertical_top" data-mapping="mapping_vertical_top">
</div>
<section class="widget widget--sidebar">
<h3 class="widget__title widget__header">
Most Popular
</h3>

<ol class="ws-list__items ws-list__items--numbered"><li class="ws-list__item ws-list__item--numbered "><div class="ws-list__item-inner"><h2 class="ws-list__title"><a href="https://www.dmagazine.com/frontburner/2018/11/has-dirk-nowitzki-played-his-last-game-with-the-mavericks/?ref=mpw" title="Has Dirk Nowitzki Played His Last Game With the Mavericks?">Has Dirk Nowitzki Played His Last Game With the Mavericks?</a></h2><span class="byline"> By <a class="byline" href="https://www.dmagazine.com/author/zac-crain-2/">Zac Crain</a></span></div></li>
<li class="ws-list__item ws-list__item--numbered "><div class="ws-list__item-inner"><h2 class="ws-list__title"><a href="https://www.dmagazine.com/frontburner/2018/11/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county/?ref=mpw" title="Party Chairs Reflect on a Night of Turnover in Dallas County">Party Chairs Reflect on a Night of Turnover in Dallas County</a></h2><span class="byline"> By <a class="byline" href="https://www.dmagazine.com/author/shawn-shinneman/">Shawn Shinneman</a></span></div></li>
<li class="ws-list__item ws-list__item--numbered "><div class="ws-list__item-inner"><h2 class="ws-list__title"><a href="https://www.dmagazine.com/food-drink/2018/11/louie-king-bbq-is-shaking-things-up-on-lowest-greenville/?ref=mpw" title="Louie King BBQ is Shaking Things Up On Lowest Greenville">Louie King BBQ is Shaking Things Up On Lowest Greenville</a></h2><span class="byline"> By Daniel Walker </span></div></li>
<li class="ws-list__item ws-list__item--numbered "><div class="ws-list__item-inner"><h2 class="ws-list__title"><a href="https://www.dmagazine.com/frontburner/2018/11/if-these-are-the-mavs-new-city-edition-jerseys-why-even-make-city-edition-jerseys/?ref=mpw" title="If These Are the Mavs&#039; New City Edition Jerseys, Why Even Make City Edition Jerseys?">If These Are the Mavs' New City Edition Jerseys, Why Even Make City Edition Jerseys?</a></h2><span class="byline"> By <a class="byline" href="https://www.dmagazine.com/author/zac-crain-2/">Zac Crain</a></span></div></li>
<li class="ws-list__item ws-list__item--numbered "><div class="ws-list__item-inner"><h2 class="ws-list__title"><a href="https://www.dmagazine.com/frontburner/2018/11/scenes-from-the-annual-black-tie-dinner-dfws-largest-lgbtq-fundraiser/?ref=mpw" title="Scenes from the Annual Black Tie Dinner, DFW&#039;s Largest LGBTQ Fundraiser">Scenes from the Annual Black Tie Dinner, DFW's Largest LGBTQ Fundraiser</a></h2><span class="byline"> By Bret Redman</span></div></li>
</ol>
</section>
<article class="card block js-block card--story  js-adunit-native display-none widget widget--sidebar" data-adunit-match="/1039436/MissEllie_native_story"></article>
<div class="adunit adunit--native adunit--desktop  adunit--native-story" data-adunit="MissEllie_native_story" data-mapping="mapping_native_desktop">
</div>
<div class="adunit adunit--vertical  js-sticky " data-adunit="MissEllie_vertical" data-mapping="mapping_vertical">
</div>
</aside>
</div>
<div class="widget widget--full-width js-stickyStop w-newsletter widget--basic-small">
<div class="container">
<h5 class="newsletter__title">
Get a weekly recap in your inbox every Sunday of our best stories from the week plus&nbsp;a&nbsp;primer&nbsp;for&nbsp;the&nbsp;days&nbsp;ahead.
</h5>
<!--[if lte IE 8]>
	<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script>
	<![endif]-->
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
<script>
	  hbspt.forms.create({ 
		css: '',
		portalId: '477347',
		formId: '5052f640-6af5-454e-b5cb-44e65cc788d2'
	  });
	</script>
</div>
</div>
<section class="w-stories widget scroller widget--full-width">
<div class="container--full w-stories-inner--simple ">
<h2 class="widget__header widget__title--simple ">
Related Content
</h2>
<div class="w-stories__items scroller__items">
<article class="w-stories__item scroller__item "><div class="block__image-wrapper w-stories__image-wrapper"><a class="ar-content" href="https://www.dmagazine.com/frontburner/2018/09/scenes-from-the-first-senate-debate-starring-beto-orourke-and-ted-cruz/?ref=rtn"><div class="slideshow-icon "><div class="slideshow-icon-inner"><svg class="icon icon--white-o" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><rect class="icon__main icon--switch" x="2" y="15" width="52" height="44" /><polygon class="icon__accent icon--stroke" fill="none" stroke="#FFFFFF" stroke-miterlimit="10" points="44,50 32,32 24,42 20,38 12,50 " /><polyline class="icon__main icon--stroke" fill="none" stroke="#000000" stroke-miterlimit="10" points="60,49 60,9 12,9 " /><circle class="icon__accent icon--fill" fill="#FFFFFF" cx="14" cy="27" r="4" /></svg></div></div><img class="lazyload image" data-srcset="									
			https://assets.dmagstatic.com/wp-content/uploads/2018/09/Photo-Sep-21-17-30-41-243x160.jpg
	 w, 										
			https://assets.dmagstatic.com/wp-content/uploads/2018/09/Photo-Sep-21-17-30-41-330x220.jpg
	 w, 										
			https://assets.dmagstatic.com/wp-content/uploads/2018/09/Photo-Sep-21-17-30-41-504x336.jpg
	 w" sizes="(max-width: px) ,
		px" data-src="									
			https://assets.dmagstatic.com/wp-content/uploads/2018/09/Photo-Sep-21-17-30-41-243x160.jpg
	 " /></a></div><div class="block__content w-stories__content"><h2 class="category"><a href="https://www.dmagazine.com/category/politics/?ref=kicker">Politics</a></h2><h1 class="w-stories__title block__title"><a href="https://www.dmagazine.com/frontburner/2018/09/scenes-from-the-first-senate-debate-starring-beto-orourke-and-ted-cruz/?ref=rtn">Scenes From The First Senate Debate, Starring Beto O&#8217;Rourke and Ted Cruz</a></h1><a class="byline" href="https://www.dmagazine.com/author/matt-goodman/">Matt Goodman</a></div></article><article class="w-stories__item scroller__item js-adunit-native display-none" data-adunit-match="/1039436/MissEllie_native_related"></article><div class="adunit adunit--native   adunit--native-related" data-adunit="MissEllie_native_related" data-mapping="mapping_native"></div><article class="w-stories__item scroller__item "><div class="block__image-wrapper w-stories__image-wrapper"><a class="ar-content" href="https://www.dmagazine.com/frontburner/2017/03/your-new-secretary-of-energy/?ref=rtn"><img class="lazyload image" data-srcset="									
			https://www.dmagazine.com/wp-content/uploads/2014/06/PERRY-HULK.png
	 w, 										
			https://www.dmagazine.com/wp-content/uploads/2014/06/PERRY-HULK.png
	 w, 										
			https://www.dmagazine.com/wp-content/uploads/2014/06/PERRY-HULK.png
	 w" sizes="(max-width: px) ,
		px" data-src="									
			https://www.dmagazine.com/wp-content/uploads/2014/06/PERRY-HULK.png
	 " /></a></div><div class="block__content w-stories__content"><h2 class="category"><a href="https://www.dmagazine.com/category/politics-and-government/?ref=kicker">Politics &amp; Government</a></h2><h1 class="w-stories__title block__title"><a href="https://www.dmagazine.com/frontburner/2017/03/your-new-secretary-of-energy/?ref=rtn">Your New Secretary of Energy</a></h1><a class="byline" href="https://www.dmagazine.com/author/zac-crain-2/">Zac Crain</a></div></article><article class="w-stories__item scroller__item "><div class="block__image-wrapper w-stories__image-wrapper"><a class="ar-content" href="https://www.dmagazine.com/frontburner/2018/03/march-for-our-lives-dallas-photos/?ref=rtn"><div class="slideshow-icon "><div class="slideshow-icon-inner"><svg class="icon icon--white-o" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="64px" height="64px" viewBox="0 0 64 64" enable-background="new 0 0 64 64" xml:space="preserve"><rect class="icon__main icon--switch" x="2" y="15" width="52" height="44" /><polygon class="icon__accent icon--stroke" fill="none" stroke="#FFFFFF" stroke-miterlimit="10" points="44,50 32,32 24,42 20,38 12,50 " /><polyline class="icon__main icon--stroke" fill="none" stroke="#000000" stroke-miterlimit="10" points="60,49 60,9 12,9 " /><circle class="icon__accent icon--fill" fill="#FFFFFF" cx="14" cy="27" r="4" /></svg></div></div><img class="lazyload image" data-srcset="									
			https://www.dmagazine.com/wp-content/uploads/2018/03/QH9A8438-James-March-243x160.jpg
	 w, 										
			https://www.dmagazine.com/wp-content/uploads/2018/03/QH9A8438-James-March-330x220.jpg
	 w, 										
			https://www.dmagazine.com/wp-content/uploads/2018/03/QH9A8438-James-March-504x336.jpg
	 w" sizes="(max-width: px) ,
		px" data-src="									
			https://www.dmagazine.com/wp-content/uploads/2018/03/QH9A8438-James-March-243x160.jpg
	 " /></a></div><div class="block__content w-stories__content"><h2 class="category"><a href="https://www.dmagazine.com/category/local-news/?ref=kicker">Local News</a></h2><h1 class="w-stories__title block__title"><a href="https://www.dmagazine.com/frontburner/2018/03/march-for-our-lives-dallas-photos/?ref=rtn">Thousands Rally in March for Our Lives in Dallas</a></h1><a class="byline" href="https://www.dmagazine.com/author/alex-macon/">Alex Macon</a></div></article> </div>
</div>
</section>
<div class="container widget--basic">
<div class="comments" id="jump-comments">
<h3 class="widget__title widget__header">
Comments
</h3>
<div id="disqus_thread"></div>
</div>
<div class="sidebar">
<div class="adunit adunit--vertical   " data-adunit="MissEllie_vertical" data-mapping="mapping_vertical">
</div>
</div>
</div>
<div class="adunit adunit--horizontal adunit--mobile_top  adunit--horizontal-top" data-adunit="MissEllie_horizontal_top" data-mapping="mapping_horizontal_mobile_top">
</div>
</div>
<footer class="footer">
<div class="container">
<div class="footer__blocks">
<div class="footer__block">
<h3 class="footer__header">
D Magazine Partners
</h3>
<div class="footer__item">
<span class="footer__item__sub">750 North St.Paul St.</span>
<span class="footer__item__sub">Suite 2100</span>
<span class="footer__item__sub">Dallas, Texas 75201</span>
</div>
<div class="footer__item">
<span class="footer__item__sub">Tel: 214.939.3636</span>
<span class="footer__item__sub">Fax: 214.748.4579</span>
</div>
<a class="footer__item" href="/cdn-cgi/l/email-protection#641601070114100d0b0a0d17102400090503051e0d0a014a070b09">CONTACT US</a>
<a class="footer__item" href="/site/newsletters">NEWSLETTERS</a>
</div>
<div class="footer__block">
<h3 class="footer__header">Sections</h3>
<ul>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/frontburner/?ref=footer">
FrontBurner
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/food-drink/?ref=footer">
Food & Drink
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/arts-entertainment/?ref=footer">
Arts & Entertainment
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/nightlife/?ref=footer">
Nightlife
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/home-garden/?ref=footer">
Home & Design
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/category/fashion/?ref=footer">
Shopping & Fashion
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/health-fitness/?ref=footer">
Health & Fitness
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/section/business-economy/?ref=footer">
Business & Economy
</a>
</li>
<li class="footer__item">
<a href="http://www.dweddings.com/?ref=footer">
Weddings
</a>
</li>
</ul>
</div>
<div class="footer__block">
<h3 class="footer__header">Publications</h3>
<ul>
<li class="footer__item">
<a href="https://www.dmagazine.com/publications/d-magazine/2018?ref=footer">
D Magazine
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/publications/d-home/2018?ref=footer">
D Home
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/publications/d-ceo/2018?ref=footer">
D CEO
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/site/subscribe/?ref=footer">
Subscribe
</a>
</li>
<li class="footer__item">
<a href="https://ssl.drgnetwork.com/ecom/DMG/app/live/subscriptions?&org=DMG&publ=DM&key_code=R1MWEB&type=R&Gift_Key=">
Renew D Magazine
</a>
</li>
<li class="footer__item">
<a href="https://ssl.drgnetwork.com/ecom/DMG/cgi/subcustserv/start?org=DMG&publ=DM">
Subscriber Services
</a>
</li>
</ul>
</div>
<div class="footer__block">
<h3 class="footer__header">Company Info</h3>
<ul>
<li class="footer__item">
<a href="http://about.dmagazine.com?ref=footer">
About Us
</a>
</li>
<li class="footer__item">
<a href="https://www.dmagazine.com/site/masthead?ref=footer">
Masthead
</a>
</li>
<li class="footer__item">
<a href="http://about.dmagazine.com/about-us/jobs/?ref=footer">
Job Openings
</a>
</li>
<li class="footer__item">
<a href="http://advertise.dmagazine.com/about-us/internship-program/?ref=footer">
Internships
</a>
</li>
<li class="footer__item">
<a href="http://about.dmagazine.com/about-us/awards/?ref=footer">
Awards
</a>
</li>
<li class="footer__item">
<a href="http://about.dmagazine.com/about-us/contact/?ref=footer">
Customer Service
</a>
</li>
</ul>
</div>
<div class="footer__block">
<h3 class="footer__header">Advertise</h3>
<ul>
<li class="footer__item">
<a href="http://about.dmagazine.com/media-kits/?ref=footer">
Media Kits
</a>
</li>
<li class="footer__item">
<a href="http://about.dmagazine.com/marketing-tools/events/?ref=footer">
Events
</a>
</li>
<li class="footer__item">
<a href="http://about.dmagazine.com/case-studies/operation-grillfest/?ref=footer">
Case Studies
</a>
</li>
<li class="footer__item">
<a href="http://advertise.dmagazine.com/about-us/contact/?ref=footer">
Contact Us
</a>
</li>
</ul>
</div>
<div class="footer__block">
<h3 class="footer__header">Connect</h3>
<ul>
<li class="footer__item">
<a href="https://www.facebook.com/DMagazineOnline?ref=footer">
Facebook
</a>
</li>
<li class="footer__item">
<a href="https://twitter.com/dmagazine?ref=footer">
Twitter
</a>
</li>
<li class="footer__item">
<a href="https://www.instagram.com/d_magazine/?ref=footer">
Instagram
</a>
</li>
<li class="footer__item">
<a href="https://www.pinterest.com/dallasmagazine/?ref=footer">
Pinterest
</a>
</li>
<li class="footer__item">
<a href="https://www.youtube.com/user/dmagazine?ref=footer">
YouTube
</a>
</li>
<li class="footer__item">
<a href="https://www.linkedin.com/company/23220?ref=footer">
LinkedIn
</a>
</li>
<li class="footer__item">
<a href="https://plus.google.com/u/0/+DMagazinePartnersDallas?ref=footer">
Google+
</a>
</li>
<li class="footer__item">
<a href="https://www.reddit.com/user/d_magazine/?ref=footer">
Reddit
</a>
</li>
</ul>
</div>
</div>
<div class="footer__footer">
Copyright © 2018, D Magazine Partners, Inc. All Rights Reserved.
<a href="//www.dmagazine.com/site/privacy-policy">Privacy Policy</a> </div>
</div>
</footer>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="dmagazine.com"></div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"dmagonline"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"519775 https:\/\/www.dmagazine.com\/?p=519775","disqusShortname":"dmagonline","disqusTitle":"Party Chairs Reflect on a Night of Turnover in Dallas County","disqusUrl":"https:\/\/www.dmagazine.com\/frontburner\/2018\/11\/party-chairs-reflect-on-a-night-of-turnover-in-dallas-county\/","postId":"519775"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/plugins/dmagazine/assets/js/jquery-ui.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/plugins/dmagazine/assets/js/jquery.beforeafter-1.4.min.js?ver=1.4'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/themes/dmagazine/dist/scripts/ajax-scripts-34a1b93e4b.js'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-content/themes/dmagazine/dist/scripts/main-b6ca32c609.js'></script>
<script type='text/javascript' src='https://www.dmagazine.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type="text/javascript">
			(function($) {
				window.dfp_targeting = {"Page":["story"],"Category":["local-government","local-news","politics","politics-and-government"],"Section":["frontburner"],"domain":["frontburner_dmagazine_com","www_dmagazine_com"],"Tag":["pete-sessions","ted-cruz","faith-johnson","colin-allred","matt-rinaldi","beto-orourke","julie-johnson","john-creuzot"]};

			})(jQuery);
		</script>

<script type="text/javascript">
    var _sf_async_config = { uid: 44922, domain: "dmagazine.com" };
    (function () {
        function loadChartbeat() {
            window._sf_endpt = (new Date()).getTime();
            var e = document.createElement('script');
            e.setAttribute('language', 'javascript');
            e.setAttribute('type', 'text/javascript');
            e.setAttribute('src',
              (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
              "js/chartbeat.js");
            document.body.appendChild(e);
        };
        var oldonload = window.onload;
        window.onload = (typeof window.onload != 'function') ?
            loadChartbeat : function () { oldonload(); loadChartbeat(); };
    })();
</script>


<script type="text/javascript">
(function(d,s,i,r) {
    if (d.getElementById(i)){return;}
    var n=d.createElement(s),e=d.getElementsByTagName(s)[0];
    n.id=i;n.src='//js.hs-analytics.net/analytics/'+(Math.ceil(new Date()/r)*r)+'/477347.js';
    e.parentNode.insertBefore(n, e);
})(document,"script","hs-analytics",300000);
</script>


<script type="text/javascript">!function(){var e=document.createElement("script");e.type="text/javascript",e.async=!0,e.src="//www.rtb123.com/tags/A9F3FE4B-AB2F-7EF2-C028-E5E732C3E01A/btp.js";var t=document.getElementsByTagName("head")[0];t?t.appendChild(e,t):(t=document.getElementsByTagName("script")[0]).parentNode.insertBefore(e,t)}();</script>


<script async src='https://tag.simpli.fi/sifitag/bae82b50-c584-0134-37fc-0cc47a63c1a4'></script>

<script id="dsq-count-scr" src="//dmagonline.disqus.com/count.js" async></script>


<script>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fdea4a9fd0","applicationID":"100413135","transactionName":"YFUGYUFUXhBWUUZZC1kfJVZHXF8NGEFbXgNbVQ==","queueTime":0,"applicationTime":1111,"atts":"TBIFFwlOTR4=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
